В новой openSuse 12.3 используется xorg 1.13 с которым не совместим проприетарный драйвер  fglx_legacy для видео карт amd radeon hd4xxx и старше.

Пользователям видео карт radeon hd4xxx и старше кране не рекомендую пытаться установить какие либо драйвера от AMD. Скорее всего после перезагрузки вы получите в лучшем случае командную строку, в худшем черный экран.

Скорее всего драйвера от AMD для карт hd4xxx и старше мы уже никогда не увидим.  Так, что владельцам видеокарт hd4xxx  остается использовать свободный драйвер radeonhd который установлен по умолчанию.

На официальном сайте openSuse уверяют, что он не хуже проприетарного.